目录linux 安装包安装前置条件修改修改配置启动docker 安装可能遇到的错误云服务器elasticsearch环境搭建-集群-CSDN博客下载链接Elastic Stack 软件的过往版本 | Elastic正在寻找 Elasticsearch、Logstash、Kibana、es-hadoop、Shield、Marvel 或我们的语言客户端的过往版本配置服务器集群时集群中节点数量没有限制大于等于2个节点就可以看做是集群了。# 注意 集群生成环境在3台机器以上这里使用1台机器来安装集群环境。问题上面的jvm内存参数配置错误了注意是-Xms。#配置集群间通信的端口号。https://blog.csdn.net/guo13313/article/details/166899598?sharetypeblogdetailsharerId166899598sharereferPCsharesourceguo13313spm1011.2480.3001.8118You Know, for SearchElastic — The Search AI Company | ElasticPower insights and outcomes with The Elasticsearch Platform. See into your data and find answers that matter with enterprise solutions designed to help you accelerate time to insight. Try Elastic toda...https://www.elastic.co/下载链接Elastic Stack 软件的过往版本 | Elastic正在寻找 Elasticsearch、Logstash、Kibana、es-hadoop、Shield、Marvel 或我们的语言客户端的过往版本您找对地方了。https://www.elastic.co/cn/downloads/past-releases#elasticsearchlinux 安装包安装#不能解压到root目录下 如果已经在root下 可以使用 mv移到 /opt/下tar -zxvf elasticsearch-7.8.0-linux-x86_64.tar.gz前置条件修改elastic不能直接通过root用户启动报错后面有需要先创建一个普通用户#创建用户useradd user_es;#设置密码passwd user_es;# 授权给新建用户chown -R user_es /opt/elasticsearch-7.8.0#用户组 chown -R user_es:user_es /opt/elasticsearch-7.8.0# 设置sudo权限#使用root用户执行visudo# 或者 vim /etc/sudoers#在root ALL(ALL) ALL下面新增user_es ALL(ALL) ALL修改普通用户打开文件次数限制#编辑limits.conf文件vi /etc/security/limits.conf#添加以下内容* soft nofile 65536* hard nofile 131072* soft nproc 2048* hard nproc 4096普通用户启动线程数限制# Centos6vi /etc/security/limits.d/90‐nproc.conf# Centos7vi /etc/security/limits.d/20‐nproc.conf#添加以下内容* soft nproc 4096普通用户增大虚拟内存vi /etc/sysctl.conf#添加以下内容:vm.max_map_count262144#保存后执行sysctl -p让配置生效sysctl -p执行完成后重新打开终端。修改配置切换到普通用户user_es修改elasticsearch.ymlsu user_es集群配置#集群名称cluster.name: my-application#节点名称node.name: node-1 # 必须#数据文件目录path.data: ./data#日志文件目录path.logs: ./logs#运行访问的网络0.0.0.0表示任意ip都匹配这样可以远程访问network.host: 0.0.0.0# 必须#http rest服务端口http.port: 9200#集群初始master选举节点cluster.initial_master_nodes: [node-1] # 必须单机配置# 单机启动 关键配置最后一行discovery.type: single-node#运行访问的网络0.0.0.0表示任意ip都匹配这样可以远程访问network.host: 0.0.0.0启动#进入到bin目录(注意不能使用root用户启动)./elasticsearch -d必须使用非root启动su user_es访问是否启动成功# 浏览器访问ip:9200# ps -ef | grep es集群单机docker 安装# 拉取镜像docker pull docker.elastic.co/elasticsearch/elasticsearch:7.8.0# 运行容器docker run -p 9200:9200 \-p 9300:9300 \-e discovery.typesingle-node \-d --name elasticsearch \docker.elastic.co/elasticsearch/elasticsearch:7.8.0查看日志内存不够用了调整一下内存参数# 运行容器 docker run -p 9200:9200 \ -p 9300:9300 \ -e discovery.typesingle-node \ -e ES_JAVA_OPTS-Xms512m -Xmx512m \ -d --name elasticsearch \ docker.elastic.co/elasticsearch/elasticsearch:7.8.0安装IK分词器https://github.com/medcl/elasticsearch-analysis-ik/releases/download/v7.8.0/elasticsearch-analysis-ik-7.8.0.ziphttps://github.com/medcl/elasticsearch-analysis-ik/releases/download/v7.8.0/elasticsearch-analysis-ik-7.8.0.zip# 在 elastic目录下的plugins下新建ik文件夹# /opt/elasticsearch-7.8.0mkdir ik#在ik目录下解压elasticsearch-analysis-ik-7.8.0.zip文件unzip elasticsearch-analysis-ik-7.8.0.zip#删除zip文件rm -f elasticsearch-analysis-ik-7.8.0.zip重启es./elasticsearch -d测试安装curl http://127.0.0.1:9200/_cat/plugins#或curl -XPOST http://127.0.0.1:9200/_analyze -H Content-Type:application/json -d {analyzer:ik_max_word,text:我是中国人}附可能遇到的问题1、root启动linux中通过包安装root用户直接启动会失败需要新建普通用户启动2、解压后的elasticsearch-7.8.0不能放到/root/目录下会有权限问题3、elasticsearch.yml配置缺少关键配置启动失败4、服务器内存不够启动直接失败调整启动参数即可5、-bash: unzip: command not found缺少命令安装一下即可yum install -y unzip